This project is read-only.
1
Vote

Groupbox - Changing state to "Normal"

description

In Silverlight 4, when setting the groupbox property "IsEnabled" to "false" gives no problem, but setting it to "true" does. Silverlight 3 did not know this problem.
There's something wrong with the duration.
 
Problem:
<vsm:VisualState x:Name="Normal">
                                <Storyboard>
                                    <DoubleAnimation 
                                                Storyboard.TargetName="BorderPart" 
                                                Storyboard.TargetProperty="Opacity" 
                                                Duration=".6" To="1"/>
                                    <DoubleAnimation 
                                                Storyboard.TargetName="TitlePart" 
                                                Storyboard.TargetProperty="Opacity" 
                                                Duration=".6" To="1"/>
                                    <DoubleAnimation 
                                                Storyboard.TargetName="ContentPart" 
                                                Storyboard.TargetProperty="Opacity" 
                                                Duration=".6" To="1"/>
                                </Storyboard>
                            </vsm:VisualState>
 
Solution:
<vsm:VisualState x:Name="Normal">
                                <Storyboard>
                                    <DoubleAnimation 
                                                Storyboard.TargetName="BorderPart" 
                                                Storyboard.TargetProperty="Opacity" 
                                                Duration="1" To="1"/>
                                    <DoubleAnimation 
                                                Storyboard.TargetName="TitlePart" 
                                                Storyboard.TargetProperty="Opacity" 
                                                Duration="1" To="1"/>
                                    <DoubleAnimation 
                                                Storyboard.TargetName="ContentPart" 
                                                Storyboard.TargetProperty="Opacity" 
                                                Duration="1" To="1"/>
                                </Storyboard>
                            </vsm:VisualState>
 
If there's another reason why it's going wrong, please tell

comments